意见箱
恒创运营部门将仔细参阅您的意见和建议,必要时将通过预留邮箱与您保持联络。感谢您的支持!
意见/建议
提交建议

HDU 5783 Divide the Sequence(水题)

来源:恒创科技 编辑:恒创科技编辑部
2023-12-20 02:29:59


Divide the Sequence


Time Limit: 5000/2500 MS (Java/Others)Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 218Accepted Submission(s): 130


HDU 5783 Divide the Sequence(水题)


Problem Description


Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.



Input


The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2⋯An.
1≤n≤1e6
−10000≤A[i]≤10000
You can assume that there is at least one solution.


Output


For each test case, output an integer indicates the maximum number of sequence division.


Sample Input


6 1 2 3 4 5 6 4 1 2 -3 0 5 0 0 0 0 0


Sample Output


6 2 5


Author


ZSTU


Source


​​2016 Multi-University Training Contest 5​​



Recommend


wange2014|We have carefully selected several similar problems for you:​​5792​​​​​5791​​​​​5790​​​​​5789​​​​​5788​​




题意:给你一个序列,让你尽可能分成更多的子序列。使得每个子序列的前缀和都大于或等于0 。输出这个的子序列 的总个数。




题解:倒序遍历序列。如果遇到的是正数,那它就是一个符合条件的子序列,如果是负数,那就继续往前遍历,直到前缀和大于等于0,就是又一个符合条件的子序列。




AC代码:


#include<bits/stdc++.h>
long long a[1000010];
int main()
{
int n;
while(~scanf("%d",&n))
{
long long sum=0;
long long num=0;
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
{
scanf("%I64d",&a[i]);
}
for(int i=n;i>=1;--i)
{

if(a[i]>=0)
{
sum++; //子序列长度
a[i]=0;
}
else
{
num=a[i];
a[i-1]+=num;

}
}
printf("%I64d\n",sum);
}
return 0;
}



上一篇: 一条SQL更新语句是如何执行的 下一篇: JetBrains 推出轻量级IDE,欲挑战VSCode霸主地位!