意见箱
恒创运营部门将仔细参阅您的意见和建议,必要时将通过预留邮箱与您保持联络。感谢您的支持!
意见/建议
提交建议

PAT 甲级 1056  Mice and Rice

来源:恒创科技 编辑:恒创科技编辑部
2024-01-09 17:37:59


1056Mice and Rice(25 point(s))

Mice and Riceis the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.


PAT 甲级 1056  Mice and Rice

First the playing order is randomly decided forNPprogrammers. Then everyNGprogrammers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. EveryNGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers:NPandNG(≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less thanNGmice at the end of the player's list, then all the mice left will be put into the last group. The second line containsNPdistinct non-negative numbersWi(i=0,⋯,NP−1) where eachWiis the weight of thei-th mouse respectively. The third line gives the initial playing order which is a permutation of0,⋯,NP−1(assume that the programmers are numbered from 0 toNP−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. Thei-th number is the rank of thei-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
经验总结:

这一题,就.....首先你得弄懂题目到底是怎么进行比赛以及如何进行排名的,如果这个弄懂了,这一题就不难了,不过难就难在弄懂上面,首先,排名是这样的,在同一轮被决定了排名的,拥有相同的排名,具体排名根据前面的人数决定(比如前面有n个人,那么这一批人的排名就为n+1),至于实现方法,用队列比较适合模拟这种淘汰类型的比赛,具体实现细节见代码~

AC代码
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
using namespace std;
const int maxn=1010;
struct mouse
{
int rank,weight;
}mice[maxn];
int main()
{
int Np,Ng,t;
scanf("%d %d",&Np,&Ng);
for(int i=0;i<Np;++i)
scanf("%d",&mice[i].weight);
queue<int> q;
for(int i=0;i<Np;++i)
{
scanf("%d",&t);
q.push(t);
}
int temp=Np,group;
while(q.size()!=1)
{
if(temp%Ng==0)
group=temp/Ng;
else
group=temp/Ng+1;
for(int i=0;i<group;++i)
{
int x=q.front();
for(int j=0;j<Ng;++j)
{
if(i*Ng+j>=temp)
break;
int front=q.front();
if(mice[front].weight>mice[x].weight)
{
x=front;
}
mice[front].rank=group+1;
q.pop();
}
q.push(x);
}
temp=group;
}
mice[q.front()].rank=1;
for(int i=0;i<Np;++i)
printf("%d%c",mice[i].rank,i<Np-1?' ':'\n');
return 0;
}

上一篇: 25587ProblemB例题5-1-2连续自然数求和 下一篇: 手机怎么远程登录云服务器?