意见箱
恒创运营部门将仔细参阅您的意见和建议,必要时将通过预留邮箱与您保持联络。感谢您的支持!
意见/建议
提交建议

找质因数..打素数表..DFS解容斥问题...

来源:恒创科技 编辑:恒创科技编辑部
2022-08-12 16:07:55


Co-prime



找质因数..打素数表..DFS解容斥问题...


Description



Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.



Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.




Input



The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).




Output



For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.




Sample Input



2


1 10 2


3 15 5




Sample Output



Case #1: 5


Case #2: 10




Hint



In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.



这题提醒的我就是在求一个数的质因数时..可以先将质数表打出来...10^9内的..质数表只需要扫到32000多(因为32000*32000>100000000了)...最终是打出3000多个质数..但要注意的是..有可能给的数就是质数..或者说有大于32000的质因数..但这样的质因数绝对最多一个...so...见程序.....


Program:

#include<iostream>
#define ll long long
using namespace std;
ll a,b,n,t,T,x,s[31],M,N,ans,p;
int Prime[40000];
void DFS(ll i,ll w,ll k)
{
for (;i<=n;i++)
{
p=w*s[i];
M+=k*(N/p);
DFS(i+1,p,-k);
}
return;
}
int main()
{
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
scanf("%I64d",&T);
ll i,j,num=0;
for (i=2;i<=33000;i++)
{
for (j=2;j*j<=i;j++)
if (i%j==0) goto A;
Prime[++num]=i;
A: ;
}
for (t=1;t<=T;t++)
{
scanf("%I64d%I64d%I64d",&a,&b,&x);
n=0;
for (i=1;i<=num;i++)
if (x%Prime[i]==0)
{
while (x%Prime[i]==0) x/=Prime[i];
s[++n]=Prime[i];
if (x==1) break;
}
if (x!=1) s[++n]=x; // 处理超过32000的质因数
a--;
M=0; N=a;
DFS(1,1,1);
M=a-M;
ans=M;
M=0; N=b;
DFS(1,1,1);
M=b-M;
ans=M-ans;
printf("Case #%I64d: %I64d\n",t,ans);
}
return 0;
}



上一篇: 租用美国服务器:潜在的风险与应对策略。 下一篇: ZeroJudge-b179空罐Cans可爱的AC自动机DP..